Fixed! Saturday 16th May 2020 05:57:39


Resolved - 16/05/2020 05:57:48 PDT


Taisetsu API check failed (server time: 16/05/2020 05:57:38 PDT)