Fixed! Saturday 16th May 2020 07:15:08


Resolved - 16/05/2020 07:15:18 PDT


Taisetsu API check failed (server time: 16/05/2020 07:14:48 PDT)