Fixed! Sunday 9th February 2020 18:34:43


Resolved - 09/02/2020 18:34:58 PST


NextCloud check failed (server time: 09/02/2020 18:34:43 PST)