Fixed! Tuesday 23rd June 2020 19:00:38


Resolved - 23/06/2020 19:01:08 PDT


NextCloud check failed (server time: 23/06/2020 19:00:38 PDT)