Fixed! Thursday 30th July 2020 22:05:48


Resolved - 30/07/2020 22:05:52 PDT


Taisetsu API check failed (server time: 30/07/2020 22:05:02 PDT)