Fixed! Monday 14th September 2020 10:52:12


Resolved - 14/09/2020 10:52:27 PDT


NextCloud check failed (server time: 14/09/2020 10:52:12 PDT)