Fixed! Tuesday 13th October 2020 23:56:58


Resolved - 13/10/2020 23:57:13 PDT


NextCloud check failed (server time: 13/10/2020 23:56:57 PDT)