Fixed! Monday 6th September 2021 19:05:53


Resolved - 06/09/2021 19:05:53 PDT


NextCloud check failed (server time: 06/09/2021 18:32:37 PDT)