Fixed! Saturday 16th May 2020 01:09:03


Resolved - 16/05/2020 01:09:13 PDT


Taisetsu API check failed (server time: 16/05/2020 01:08:48 PDT)